Форум вебмастеров

vBulletin 4.x.x Общая инфомация и обмен опытом по работе с vBulletin 4.x.x

Ответ
 
LinkBack Опции темы
Старый 09.12.2013, 14:53 #1 (Ссылка)
Подглядывающий
Дополнительная информация
По умолчанию

В начале установки форума vBulletin появляется ошибка


Всем доброго времени суток.

В начале установки форума появляется ошибка которая находиться выше установки

Цитата:
Строгие стандарты : Номера для статического метода vB_Shutdown :: экземпляра () не должен вызываться статически, предполагая $ это от несовместимых контексте в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_core.php на линии 3314

Строгие стандарты : Декларация vB_Database_Alter_MySQL :: drop_index () должен быть совместим с vB_Database_Alter :: drop_index () в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php на линии 882

строгими стандартами : Декларация vB_Database_Alter_MySQL :: add_index () должен быть совместим с vB_Database_Alter :: add_index () в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php на линии 882

Строгие стандарты : Декларация vB_Database_Alter_MySQL :: add_field () должен быть совместим с vB_Database_Alter :: add_field () в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php на линии 882

Строгие стандарты : Декларация vB_Database_Alter_MySQL :: drop_field () должен быть совместим с vB_Database_Alter :: drop_field () в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php на линии 882

Строгие стандарты : Декларация vB_Database_Alter_MySQL :: запроса () должны быть совместимы с vB_Database_Alter :: запроса () в / var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php на линии 882
на английском:

Цитата:
Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_core.php on line 3314

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field() in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php on line 882

Strict Standards: Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query() in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php on line 882
Думал, ладно, фиг с ней, нажал "начать установку" и появляется вот это:

Цитата:
Unexpected Text:
<br />
<b>Strict Standards</b>: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_core.php</b> on line <b>3314</b><br />
<br />
<b>Strict Standards</b>: Declaration of vB_Database_Alter_MySQL::drop_index() should be compatible with vB_Database_Alter::drop_index() in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php</b> on line <b>882</b><br />
<br />
<b>Strict Standards</b>: Declaration of vB_Database_Alter_MySQL::add_index() should be compatible with vB_Database_Alter::add_index() in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php</b> on line <b>882</b><br />
<br />
<b>Strict Standards</b>: Declaration of vB_Database_Alter_MySQL::add_field() should be compatible with vB_Database_Alter::add_field() in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php</b> on line <b>882</b><br />
<br />
<b>Strict Standards</b>: Declaration of vB_Database_Alter_MySQL::drop_field() should be compatible with vB_Database_Alter::drop_field() in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php</b> on line <b>882</b><br />
<br />
<b>Strict Standards</b>: Declaration of vB_Database_Alter_MySQL::query() should be compatible with vB_Database_Alter::query() in <b>/var/www/crysiss29/data/www/forum.csskms.ru/includes/class_dbalter.php</b> on line <b>882</b><br />
<?xml version="1.0" encoding="windows-1252"?>
<upgrade>
<message replace="0">Connection successful</message>

В конфиге делал все по образцу с этой темы : https://wmboard.net/vbulletin/2204-k...vbulletin.html

Пожалуйста помогите!
sntg вне форума   Ответить с цитированиемОтветить с цитированием


Старый 09.12.2013, 15:45 #2 (Ссылка)
Модератор
Дополнительная информация
По умолчанию

Решение данной проблемы подсмотрел у Александра

Находим файл
install/init.php строка 25.

Делаем так

Цитата:
// try to force display_errors on
@ini_set('display_errors', true)
lukamal вне форума   Ответить с цитированиемОтветить с цитированием

Старый 09.12.2013, 16:00 #3 (Ссылка)
Подглядывающий
Дополнительная информация
По умолчанию

// set the current unix timestamp
define('TIMENOW', time());
define('SAPI_NAME', php_sapi_name());
define('SAFEMODE', (@ini_get('safe_mode') == 1 OR strtolower(@ini_get('safe_mode')) == 'on') ? true : false);

Цитата:
// try to force display_errors on
@ini_set('display_errors', true);
вроде все верно стоит.

Щас захожу в установку, сразу же появляется это:

Цитата:
Strict Standards: Non-static method vB_Shutdown::instance() should not be called statically, assuming $this from incompatible context in /var/www/crysiss29/data/www/forum.csskms.ru/includes/class_core.php on line 3314

Fatal error: Call to undefined function verify_optimizer_environment() in /var/www/crysiss29/data/www/forum.csskms.ru/install/includes/class_upgrade.php on line 902
sntg вне форума   Ответить с цитированиемОтветить с цитированием

Старый 09.12.2013, 16:04 #4 (Ссылка)
Администратор
Дополнительная информация
По умолчанию

Это хостинг. 99% из 100.
Veter вне форума   Ответить с цитированиемОтветить с цитированием

Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Регистрация с Theme My Login не появляется Yopt WordPress 5 13.04.2018 23:01
Ошибка установки vBulletin 3.8.7 Quebec vBulletin 2 06.02.2016 17:09
Перевод установки хака Steam Connect для vBulletin Grande Хаки vBulletin 4.x.x 3 10.01.2016 13:52
Ошибка базы данных при просмотре комбинированного или древовидного вида форума Sayf vBulletin 6 03.09.2013 12:08
Хак установки SAPE на vBulletin - SapeIn Full Veter Хаки vBulletin 0 03.04.2013 20:23


Текущее время: 10:45. Часовой пояс GMT +3.

Powered by vBulletin®
Copyright ©2000 - 2021, WMboard.
Перевод: zCarot
 

Форум вебмастеров

Здесь делают сайты, учатся на них зарабатывать. Ты новичок, и ничего не понимаешь в создании сайтов и в интернет заработке? Не знаешь ответа на вопрос по сайтостроению? Мучают вопросы сео оптимизации?

Не беда, присоединяйся к сообществу вебмастеров, и зарабатывай вместе с нами!