Форум вебмастеров

WordPress Система управления сайтом WordPress

Результаты опроса: Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?
да, нормально 1 50.00%
нет, это не правильно 1 50.00%
Голосовавшие: 2. Вы ещё не голосовали в этом опросе

Ответ
 
LinkBack Опции темы
Старый 16.08.2019, 12:57 #1 (Ссылка)
Новичок
Дополнительная информация
По умолчанию

Нормально если вебмастер сделал сайт на wordpress, работающий только на PHP 5.6?


Здравствуйте, коллеги,
попрошу вас высказать своё мнение по поводу одной спорной ситуации
Я - сис. админ хостинга. Одному из моих клиентов вебмастер сделал сайт на wordpress, работающий только на PHP 5.6 (я это проверил, но выяснилось это уже после 100% оплаты за работу, это было около 40 тыс. руб). На более свежих версиях PHP (7.1, 7.2), сайт работать отказывается, выдавая ошибку (все подробности ниже). Для того, чтобы сайт заработал, этот вебмастер потребовал еще 25 тыс. руб. Насколько вы считаете эту ситуацию нормальной?

Подробности:
Вот наша переписка
...
Сис. админ. Олег:
Здравствуйте, Алексей,
установил сайт на два разных хостинга (****) , на каждом из них сайт не работает. Подозреваю, что из-за более старой версии php, использующейся у вас на локали ...
Вот ошибка:
# tail -1 /home/new/logs/error_log
[Sat Aug 10 22:35:33.472507 2019] [proxy_fcgi:error] [pid 24905] [client:60598] AH01071: Got error 'PHP message: PHP Parse error: syntax error, unexpected '}', expecting end of file in /home/new/public_html/wp-content/themes/travelwithme/asstes/widget-social.php on line 77\n'
на втором хостинге тоже самое
Админка работает и полагаю, что проблема здесь ****

Вебмастер Алексей:
Здесь вопрос не в старосте версии, а том чтобы настроить и синхронизировать версии PHP на хостинге под сайт , обычно так делается, у меня же на хостинге всё работает)))

Сис. админ. Олег:
Алексей,
что вы предлагаете мне сделать под словами "настроить и синхронизировать версии PHP" ???
Какая версия PHP у вас используется?
Вот ошибка: ***
Что вы мне предлагаете с ней делать?????

Вебмастер Алексей:
Сожалею, но я увы не владею необходимыми знаниями, и потому в подобных случаях я обращаюсь за помощью к провайдеру хостинга , которые всегда быстро и качественно решают любую проблему! Поэтому если в данном случае Вы обязались выступать в роли технической поддержки сервера, то видимо это нужно и разбираться именно Вам!

Сис. админ. Олег:
Алексей, повторяю свой вопрос, какая версия PHP на вашем хостинге?

Вебмастер Алексей:
Совершенно не в курсе((

Сис. админ. Олег:
Придётся вам помочь, у вас стоит версия PHP 5.6.36
Она устарела, имеет проблемы с безопасностью и давно не поддерживается: https://www.php.net/supported-versions.php
Использование такой версии PHP на хостинге не приемлемо.
Новые версии PHP не поддерживают некоторые потенциально небезопасные функции, откуда часто и возникают ошибки "PHP Parse error:
syntax error, unexpected"

Вебмастер Алексей:
На сегодняшний день версия PHP 5.6.36 является вполне современной и соответствующей всем требованием безопасности! Ну если Вы так сильно хотите, то пожалуйста согласовывайте это с Игорем, так как увы но эта работа будет платной и весьма не дешевой что-то около 25 000 р. так как придется подтягивать программиста и программить сайт, как говорится любой каприз))) Но мне кажется гораздо проще сделать на вашем сервере данную версию доступной для использования

Сис. админ. Олег:
Алексей,
еще раз, вот официальный сайт PHP
https://www.php.net/supported-versions.php
Специально для вас расшифровываю, PHP 5.6 не обновляется 1 января 2017 года, а с 1 января 2019 вообще не поддерживается, уже 8 месяцев не выходят даже обновления безопасности, вы вообще понимаете то, о чем пишете и что вообще предлагаете????
Вы хотите чтобы сайт был уязвим и создавал потенциальную брешь в безопасности сервера???
О каком капризе вообще идет речь если эксплуатация сайта в таком виде просто небезопасна???
Если завтра выпустят эксплойт, легко ломающий все сайты на этой версии, то сайт только срочно выключать, без вариантов...и такое бывало много раз, за 19 лет моей работы...
Я считая, что в августе 2019 сделать сайт, не работающий на версии PHP 7.2 и предложить его допилить за 25000 для того, чтобы он работал - это просто верх непрофессионализма.
Я просто в шоке.

Вебмастер Алексей:
Да и на всякий случай: на сегодняшний день в интернете более 98 % сайтов работают на 5-й и еще более ранних версиях PHP и процесс перехода на новый 7-е весьма длителен! И Порядок вещей таков: что именно хостеры настраивают свой софт под сайт и никак не наоборот!)))

Сис. админ. Олег:
Категорически не согласен с вами.
Кроме того, если какие-то сайты и работают на 5 версии, то это только потому, что были сделаны много-много лет назад, а их владельцы ждут, пока их взломают,
но уж сайт, сделанный в августе 2019 и не работающий на PHP 7.2 - это просто нонсенс!!!

Вебмастер Алексей:
Уважаемый! А я считаю верхом непрофессионализма не разбираться в сайтостроении и при этом пытаться что-то доказывать! А Вы вообще понимаете почему на сегодняшний день огромное количество сайтов делаются еще на 5 PHP?
А почему при переходе на 7 многие компоненты сайта не работают?
Почему все хостеры полностью поддерживают версию PHP 5.6? А вот кстати с 7-кой бывают проблемы?
И почему все переходы версий PHP растягиваются на 3-5 лет?
Я в шоке от Вас что Вам просто лень или опять отсутствие профессиональных знаний УЖЕ ВТОРОЙ МЕСЯЦ мешают установить готовый и работающий сайт на сервере!!!
ЗА 12 лет практики я впервые столкнулся с таким дилетантским отношением!!!

Отсюда вывод:
1. Вы абсолютно не понимаете сути вопроса!
2. Пытаетесь решить свои проблемы чужими руками.
3. Допускаете в адрес оппонента не корректные выпады!

На основании всего вышеизложенного и опираясь на то что я передал заказчику сайт в полной готовности и работоспособности, а также в связи с полным отсутствием желания решать свои проблемы со стороны представителя заказчика, я далее прекращаю всяческие рассуждения на эту тему. Так как не вижу смысла убеждать Вас в том чего Вы не желаете понять!


Удачи Вам юноша и более не пишите на этот адрес!


Сис. админ. Олег:
Найдите одну, только хотя бы одну единственную веб-студию (ну кроме вас, конечно )), которая создает сайты, не работающие на 7.2 PHP !!!
И опыта у меня побольше вашего лет так этак на 10 как минимум.... даже если предположить что у вас 12 лет практики ))
А ваша фраза, как веб-мастера, что вы "Совершенно не в курсе((" на какой версии PHP у вас работает сайт, при декларируемых 12 годах практики просто .... обескураживает ( выражусь мягко
...
В декабре 2019 года разработчики wordpress планируют отказаться от поддержки php 5.6
...
Дальше Вебмастер Алексей не отвечает
--Oleg-- вне форума   Ответить с цитированиемОтветить с цитированием


Старый 16.08.2019, 17:18 #2 (Ссылка)
Администратор
Дополнительная информация
По умолчанию

Цитата:
Сообщение от --Oleg-- Посмотреть сообщение
Насколько вы считаете эту ситуацию нормальной?
Ну а что тут криминального? 5.6 это не самая древняя версия php На ней 80% сайтов рунета работает. У меня есть сайты работающие на 5.2, 5.3, 5.4, 5.6 и только несколько работает на семерке.

Что касается претензии фрилансеру, то если в ТЗ не было указано версии php на которой должен работать сайт, ваши упреки несостоятельны.
Вы дольше переписку вели. Обновите вордпресс до последней версии и он у вас заработает на семерке Делов то.
Veter вне форума   Ответить с цитированиемОтветить с цитированием

Старый 17.08.2019, 11:02 #3 (Ссылка)
Профи
Дополнительная информация
По умолчанию

"Вот этот шляпный базар для чего нам сейчас?" (С) Стражи Галактики 2

открываем файл /wp-content/themes/travelwithme/asstes/widget-social.php в любом редакторе, который подсвечивает синтаксис, смотрим, где там баг с фигурной скобкой возле строки 77 и исправляем
делов-то... на пару минут...

Цитата:
Сообщение от Veter Посмотреть сообщение
Обновите вордпресс до последней версии и он у вас заработает на семерке
баг-то в кастомной теме, она ж не обновится

ВП куда менее привередлив к версии ПХП, чем свежие воблы
всё, что работает на 5.6, будет работать и на семёрке
синтаксическая ошибка, которая попала в лог, вообще не имеет отношения к версии ПХП, ну, может, 5.6 там просто варнинг выставляет
это просто баг, может, при копировании, может, описка, ну бывает...
Льюви вне форума   Ответить с цитированиемОтветить с цитированием
Пользователь сказал cпасибо:
Veter (17.08.2019)

Старый 17.08.2019, 13:02 #4 (Ссылка)
Новичок
Дополнительная информация
По умолчанию

Коллеги, большое спасибо за ответы.
--Oleg-- вне форума   Ответить с цитированиемОтветить с цитированием

Старый 18.08.2019, 13:08 #5 (Ссылка)
Новичок
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
Ну а что тут криминального? 5.6 это не самая древняя версия php На ней 80% сайтов рунета работает. У меня есть сайты работающие на 5.2, 5.3, 5.4, 5.6 и только несколько работает на семерке.

Что касается претензии фрилансеру, то если в ТЗ не было указано версии php на которой должен работать сайт, ваши упреки несостоятельны.
Вы дольше переписку вели. Обновите вордпресс до последней версии и он у вас заработает на семерке Делов то.
Wordpress сейчас последней версии... там темплейт древний, он не работает на php 7
--Oleg-- вне форума   Ответить с цитированиемОтветить с цитированием

Старый 18.08.2019, 17:06 #6 (Ссылка)
Администратор
Дополнительная информация
По умолчанию

Цитата:
Сообщение от --Oleg-- Посмотреть сообщение
там темплейт древний, он не работает на php 7
Да, я был невнимателен. Совету Льюви последуйте.
Veter вне форума   Ответить с цитированиемОтветить с цитированием

Старый 18.08.2019, 18:47 #7 (Ссылка)
Профи
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
Совету Льюви последуйте.
Мастер Йода?
Льюви вне форума   Ответить с цитированиемОтветить с цитированием

Старый 19.08.2019, 15:43 #8 (Ссылка)
Администратор
Дополнительная информация
По умолчанию

Нипонял
Veter вне форума   Ответить с цитированиемОтветить с цитированием

Старый 10.04.2020, 06:58 #9 (Ссылка)
Местный
Дополнительная информация
По умолчанию

Маразм конечно... ведь есть такие плагины, которые устанавливаются с поздними версиями php, приходится на хостинге обновлять версии. И как тут быть?
alena вне форума   Ответить с цитированиемОтветить с цитированием

Старый 10.04.2020, 11:53 #10 (Ссылка)
Новичок
Дополнительная информация
По умолчанию

Цитата:
Сообщение от alena Посмотреть сообщение
Маразм конечно... ведь есть такие плагины, которые устанавливаются с поздними версиями php, приходится на хостинге обновлять версии. И как тут быть?
Спасибо за Ваш ответ, Алёна
--Oleg-- вне форума   Ответить с цитированиемОтветить с цитированием

Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Если делать новый сайт на старом домене? Аркадий 10 Домены 2 25.11.2013 17:07
О чем делать сайт, если толком ни в чем не разбираешься? Pingvin Вопросы от новичков 13 11.11.2013 12:35
Можно ли нормально зарабатывать в покере, казино, рулетке? Barmaley Заработок для вебмастера 25 15.10.2013 15:45
Взломали сайт на Wordpress'e SK CREW' Олег Добротин WordPress 1 20.05.2012 19:16
Загруженность процессора составляет почти всегда на 100%, это нормально? (Пентиум 4) unreal100 Проблемы с железом 4 30.05.2011 15:36


Текущее время: 14:31. Часовой пояс GMT +3.

Powered by vBulletin®
Copyright ©2000 - 2020, WMboard.
Перевод: zCarot
 

Форум вебмастеров

Здесь делают сайты, учатся на них зарабатывать. Ты новичок, и ничего не понимаешь в создании сайтов и в интернет заработке? Не знаешь ответа на вопрос по сайтостроению? Мучают вопросы сео оптимизации?

Не беда, присоединяйся к сообществу вебмастеров, и зарабатывай вместе с нами!