Старый 25.09.2011, 03:37 #1 (Ссылка)
Аватар для Boss
Чёрный кардинал
 
Регистрация: 19.06.2010
Адрес: Pirate Bay
Моя смс: Pirate vBulletin
Сообщений: 1,702
Записей в дневнике: 1
Сказал(а) спасибо: 205
Поблагодарили 390 раз(а) в 237 сообщениях
Репутация: 410
Boss Boss вне форума
Чёрный кардинал
Дополнительная информация
Лампочка

Скачать vBulletin 3.8.x


Движок vBulletin пожалуй самый достойный форумный движок, который есть сейчас в наличие

Хотя уже давно вышла четвертая линейка, но я лично считаю, что третья остается самый надежной и стабильной версией

По большому счету нет разницы какую версию вы поставите в качестве своего форума. Это может быть версия vBulletin 3.8.4 и vBulletin 3.8.5, а также vBulletin 3.8.7.

Все они достаточно надежны и стабильны.
Для того, чтобы узнать подробности необходимо вступить в группу.

Последний раз редактировалось Veter; 12.08.2017 в 19:02.
Boss вне форума   Ответить с цитированиемОтветить с цитированием
5 пользователя(ей) сказали cпасибо:
Helenka (02.06.2013), inso (03.09.2013), Veter (25.09.2011), Аркадий 10 (14.12.2012), Ночная странница (08.03.2014)
Старый 16.08.2015, 23:52 #81 (Ссылка)
Местный
 
Регистрация: 16.08.2015
Адрес: Aberdeen
Моя смс: vBulletin 4.2.3
Сообщений: 223
Сказал(а) спасибо: 71
Поблагодарили 32 раз(а) в 25 сообщениях
Репутация: 42
Usta Usta вне форума
Местный
Дополнительная информация
По умолчанию

Я вообще только как 2 дня назад решил создать форум, я не программист и мой первый сайт это wix - конструктор, но я там добился неплохих успехов и за месяц трудов и ознакомлений с SEO и так далее... вобщем сайт хороший получился... И вот решил форум создать, написал на форуме фрилансер, что нужен форум и начали предлагать мне сделать форум, всего за 1-3т.р. - некоторые не понимали что мне надо...научить меня или самим сделать!!! Но с условием, что надо покупать двигатель... в итоге я нашел кто продает "булку"... Вчера купил домен, впервые, сегодня купил хостинг на Хостланде - все это может показаться ерундой кто в теме, но на выбор ушло очень много времени...и домена и хостинга... Скачал тут движок на тройку, начал устанавливать... Ничего не получилось - буду завтра пробовать... И я думаю, я не единственный, кто в этом направлении нуб Простите за оффтоп.
Usta вне форума   Ответить с цитированиемОтветить с цитированием

Старый 16.08.2015, 23:57 #82 (Ссылка)
Аватар для Льюви
Профи
 
Регистрация: 22.05.2012
Адрес: Харьков
Сообщений: 1,197
Сказал(а) спасибо: 465
Поблагодарили 970 раз(а) в 554 сообщениях
Репутация: 1130
Льюви Льюви вне форума
Профи
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Usta Посмотреть сообщение
Простите за оффтоп.
это не оффтоп, всё нормально
Вы рассказали пару слов о себе
мы все были новичками, все когда-то ставили форум "в первый раз"

Цитата:
Сообщение от Usta Посмотреть сообщение
начал устанавливать... Ничего не получилось - буду завтра пробовать...
спрашивайте, что именно "не получилось"
Льюви вне форума   Ответить с цитированиемОтветить с цитированием
Пользователь сказал cпасибо:
YURSHAT (17.08.2015)
Старый 17.08.2015, 02:14 #83 (Ссылка)
Аватар для YURSHAT
Подглядывающий
 
Регистрация: 20.07.2015
Адрес: Харьков
Моя смс: vBulletin
Сообщений: 78
Сказал(а) спасибо: 48
Поблагодарили 36 раз(а) в 30 сообщениях
Репутация: 96
YURSHAT YURSHAT вне форума
Подглядывающий
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
Хотя я и ставил последнюю тройку еще версии 3.8.7, но уже на нее выходили разные патчи, которые я так и не поставил.
А все почему? Потому как вы знали, что никаких уязвимостей в 3.8.7 нет и всякие мелкие правки новых версий не имеют особого смысла для вас. А аргумент, что 3.8.4 от старых, а 3.8.9 от новых, очень слабый. Вот первые версии четверки были от Кира, Майка и КО, но это ведь не значит, что юзверю лучше 4.0 поставить, нежели 4.2.3.

Да, мы глумимся над новой коммандой разрабов, но там явно люди не глупее нас с вами сидят. У них пока получается кривой двиг, но они ведь новую архитектуру замутили, все перелопатили и по ходу сами уже запутались и не понимают, что у них получается и что делать дальше. С тройкой другая ситуация. Править 3.8.4 и выше они взялись не от большой любви к тройке. Им вообще на нее плевать. Просто их баг-трекер наполняется жалобами и учитывая тот факт, что двиг коммерческий, они обязаны править эти баги. Вот время от времени и выпускают новые версии тройки. Но они там не добавляют новый функционал и не расширяют существующий и что самое важное, делать это не собираются. В основном они просто подшаманивают двиг под актуальный софт, не более.

Человек покупает себе новый хост и вряд ли там будет PHP ниже 5.3, а если так, поставив 3.8.4 он получит гемморой.
Цитата:
Сообщение от Veter Посмотреть сообщение
поправьте файлы чтобы форум установился без проблем на php 5.4, 5.5,
Veter, да я то могу поправить, но смысл? В принципе, на выходе получится тот же 3.8.9 Да и ни кому это будет не нужно, так как человеку проще поставить офф релиз чем некую сборку от какого-там YURSHAT'a Тем более разница не велика. С 3.6 я проделал этот финт, но там немного другая ситуация и 3.6 IB уже никогда не обновит. Так как во-первых, я люблю эту версию , а во-вторых, знаю немало людей, которые сидят на 3.6 и не собираются обновлятся, а софт на сервере обновить не прочь.

Цитата:
Сообщение от Usta Посмотреть сообщение
И я думаю, я не единственный, кто в этом направлении нуб
А ни кто вас в этом и не упрекает. Как уже сказала Лью, мы все были нубами. Я о том, что не нужно ставить перед новичками непосильных задач, особенно когда это неоправдано.

Последний раз редактировалось YURSHAT; 17.08.2015 в 02:18.
YURSHAT вне форума   Ответить с цитированиемОтветить с цитированием
Старый 17.08.2015, 03:14 #84 (Ссылка)
Аватар для Veter
Администратор
 
Регистрация: 01.01.1970
Адрес: На wmboard
Моя смс: vBulletin 3.x.x, DLE, WordPress, XenForo
Сообщений: 9,224
Записей в дневнике: 17
Сказал(а) спасибо: 2,058
Поблагодарили 2,666 раз(а) в 1,930 сообщениях
Репутация: 2676
Veter Veter вне форума
Администратор
Дополнительная информация
По умолчанию

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
но это ведь не значит, что юзверю лучше 4.0 поставить, нежели 4.2.3.
Не знаю... я ставил 4.2.0

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
Человек покупает себе новый хост и вряд ли там будет PHP ниже 5.3, а если так, поставив 3.8.4 он получит гемморой.
Хм... да нет там никакого геморроя. Один форум я держу на 5.2, еще на одном обновили ПО на 5.3. Все остальные на пхп 5.4. 15 минут дел то всего поправить файлы, инструкции по правке которых лежат.
Я не был уверен поставится ли вобла 3.8.4 на пхп 5.4, с нуля, ну ставится, проблем нет.
Цитата:
Сообщение от YURSHAT Посмотреть сообщение
С 3.6 я проделал этот финт
3.6.4 и у меня лежит Правда нигде уже не стоит.

Так вот. Сегодня нашел у себя пхп 5.4 и попробовал как ставится 3.8.4 вобла. Как писал выше никаких проблем нет. Исходные файлы правил. На чистом форуме без хаков никаких проблем. Кому важно именно 3.8.4 под пхп 5.4 можно забрать в первом посте. Ошибки при установке есть. Есть string и deprecated, но все ставится. После установки форум чистый, и выглядит так:



То есть проблем с ним нет.

Также добавил ссылку на скачивание 3.8.8 PL1. Версии 3.8.9 у меня нет.
Все в первом посте.
Veter вне форума   Ответить с цитированиемОтветить с цитированием
Старый 17.08.2015, 05:33 #85 (Ссылка)
Аватар для YURSHAT
Подглядывающий
 
Регистрация: 20.07.2015
Адрес: Харьков
Моя смс: vBulletin
Сообщений: 78
Сказал(а) спасибо: 48
Поблагодарили 36 раз(а) в 30 сообщениях
Репутация: 96
YURSHAT YURSHAT вне форума
Подглядывающий
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
После установки форум чистый, и выглядит так
Ну у 3.8.9 уровень ошибок выше (что уже небольшой + к 3.8.9)

У 3.8.4
Код:

Блок отключен
У 3.8.9
Код:

Блок отключен
Ну и форум далеко не "чистый". Покликайте по опциям в админке (настройки, стили), попробуйте загрузить аттач\аватар, откройте соц группы и т.д.

Ну и включите "Режим отладки".

Все это свалится на голову человека, который первый раз в жизни видит воблу как админ. Вот повеселится Хотя мог поставить последнюю актуальную версию 3.8.9, где все это дело разрабы уже поправили.

Цитата:
Сообщение от Veter Посмотреть сообщение
string
Вообще-то Strict

ЗЫ. Вы там это, папочку cgi-bin в дистре забыли удалить

Последний раз редактировалось YURSHAT; 17.08.2015 в 05:35.
YURSHAT вне форума   Ответить с цитированиемОтветить с цитированием
Пользователь сказал cпасибо:
Veter (17.08.2015)
Старый 17.08.2015, 11:07 #86 (Ссылка)
Аватар для Льюви
Профи
 
Регистрация: 22.05.2012
Адрес: Харьков
Сообщений: 1,197
Сказал(а) спасибо: 465
Поблагодарили 970 раз(а) в 554 сообщениях
Репутация: 1130
Льюви Льюви вне форума
Профи
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
Так вот. Сегодня нашел у себя пхп 5.4 и попробовал как ставится 3.8.4 вобла. Как писал выше никаких проблем нет. Исходные файлы правил. На чистом форуме без хаков никаких проблем.
я тоже люблю говорить, что тройка правится под новые ПХП во время просмотра киношки, в рекламных паузах... и тоже довольно часто занимаюсь этой ерундой
Но одно дело - форум, которому лет пять-семь, там уже часть файлов правлена, куча хаков, чёрт ногу сломит, что от чего зависит - да, проще сесть и вправить файлы (и движка, и хаков, и модули, если уж быть точной, потому что там тоже... разное встречается), чем обновлять: всё равно файлы править
И совсем другое дело - форум с нуля. Не вижу особого кайфа начинать работу с форумом с правки файлов

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
Вот время от времени и выпускают новые версии тройки. Но они там не добавляют новый функционал и не расширяют существующий и что самое важное, делать это не собираются.
ну... в 3.8.7, если мне память не изменяет, они таки добавили "отключение проверки перенаправлений для доменов" или как-то так... что вызывало кучу головняка у тех, кто юзает хак вбспонсорс, например
и конфиг растёт, как на дрожжах

===
лично для меня есть только один ощутимый плюс в версии 3.8.4 в отличие от более поздних
на 3.8.4 без проблем и без биться кувалдой становится 99% существующих для тройки хаков, начиная от разработок для 3.6 (и даже некоторые от 3.5)
с 3.8.6 разработчики объявили тотальную "деглобалицацию", поэтому хаки, которые подразумевают глобал $выбуллетинЬ, уже работать без напильника не хотят
на тройку есть очень много классных хаков, многие из которых не обновлялись авторами со времён 3.6-3.7, и некоторые из этих хаков (вот неожиданный поворот) продолжают работать и на пхп 5.3-5.4
так что... приходится думать, что же ставить...
как-то так...
Льюви вне форума   Ответить с цитированиемОтветить с цитированием
2 пользователя(ей) сказали cпасибо:
Viuga (17.08.2015), YURSHAT (17.08.2015)
Старый 17.08.2015, 20:06 #87 (Ссылка)
Аватар для YURSHAT
Подглядывающий
 
Регистрация: 20.07.2015
Адрес: Харьков
Моя смс: vBulletin
Сообщений: 78
Сказал(а) спасибо: 48
Поблагодарили 36 раз(а) в 30 сообщениях
Репутация: 96
YURSHAT YURSHAT вне форума
Подглядывающий
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Льюви Посмотреть сообщение
ну... в 3.8.7, если мне память не изменяет, они таки добавили "отключение проверки перенаправлений для доменов" или как-то так... что вызывало кучу головняка у тех, кто юзает хак вбспонсорс, например
и конфиг растёт, как на дрожжах
Ну это одна опция, которую они добавили. Но опять же, разрабы при обновлении движка не обязаны сохранять совместимость с каким-то там vB Sponsors. Это vB Sponsors должен был обновится, если у него чего-то там не сростается. Да и это единичные случаи. 98% процентов того, что работает на 3.8.4, должно работать и на 3.8.9. А если что-то "не взлетело", то обычно правится за пару минут. Да и многие старые хаки написаны теми еще кодерами Частенько на саппорте наталкиваешся на такие. Потому не удивительно, что такая работа может не взлететь на новой версии движка.

Цитата:
Сообщение от Льюви Посмотреть сообщение
с 3.8.6 разработчики объявили тотальную "деглобалицацию", поэтому хаки, которые подразумевают глобал $выбуллетинЬ, уже работать без напильника не хотят
Речь о том, что из некоторых функций убрали global $vbulletin? Если убрали, значит этот объект там просто не использовался. Разве это неправильно? Разве такого не должно быть? Если хакопейсателю нужен этот объект - пусть он его и объявляет.

Цитата:
Сообщение от Льюви Посмотреть сообщение
на тройку есть очень много классных хаков, многие из которых не обновлялись авторами со времён 3.6-3.7, и некоторые из этих хаков (вот неожиданный поворот) продолжают работать и на пхп 5.3-5.4
так что...
Ну ничего удивительного. Все таки PHP не так уж кардинально и меняется с каждой версией и далеко не все функции становятся Deprecated

И самое главное - речь не шла о том, что круче глобально, 3.8.4 или 3.8.9. Совет использовать 3.8.9 был дан конкретному человеку, который сразу сказал, что новичок в этом деле. Потому как 3.8.4 ему изначально нужно будет править. Что мне кажется не есть гуд. А там уж дело добровольное

Последний раз редактировалось YURSHAT; 17.08.2015 в 20:09.
YURSHAT вне форума   Ответить с цитированиемОтветить с цитированием
Старый 17.08.2015, 20:43 #88 (Ссылка)
Аватар для Veter
Администратор
 
Регистрация: 01.01.1970
Адрес: На wmboard
Моя смс: vBulletin 3.x.x, DLE, WordPress, XenForo
Сообщений: 9,224
Записей в дневнике: 17
Сказал(а) спасибо: 2,058
Поблагодарили 2,666 раз(а) в 1,930 сообщениях
Репутация: 2676
Veter Veter вне форума
Администратор
Дополнительная информация
По умолчанию

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
Покликайте по опциям в админке (настройки, стили), попробуйте загрузить аттач\аватар, откройте соц группы и т.д.
Не могу, его уже нет. Использовался действующий хостер, который отрицательно относится к пиратским версиям движка. Отображение аватаров и миниатюр я правил. Адаптацию к виндовой кодировке не делал, многие ставят UTF. Там этой проблемы нет.

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
Все это свалится на голову человека, который первый раз в жизни видит воблу как админ.
Человек, который в первый раз в жизни увидит воблу как админ, понятия не имеет как включается режим отладки, а может не узнает никогда.

Цитата:
Сообщение от YURSHAT Посмотреть сообщение
Вы там это, папочку cgi-bin в дистре забыли удалить
Ну всегда чего-нибудь забудешь...
То есть вы считаете, что для новичков выложенный дистрибутив 3.8.4 лишний?
Veter вне форума   Ответить с цитированиемОтветить с цитированием
Старый 17.08.2015, 21:17 #89 (Ссылка)
Аватар для YURSHAT
Подглядывающий
 
Регистрация: 20.07.2015
Адрес: Харьков
Моя смс: vBulletin
Сообщений: 78
Сказал(а) спасибо: 48
Поблагодарили 36 раз(а) в 30 сообщениях
Репутация: 96
YURSHAT YURSHAT вне форума
Подглядывающий
Дополнительная информация
По умолчанию

Цитата:
Сообщение от Veter Посмотреть сообщение
Отображение аватаров и миниатюр я правил
Я про заливку аттачей newattachment.php


Цитата:
Сообщение от Veter Посмотреть сообщение
Адаптацию к виндовой кодировке не делал, многие ставят UTF. Там этой проблемы нет.
Причем тут кодировка? Я тоже использую исключительно UTF-8. Но она тут никаким боком...

Цитата:
Сообщение от Veter Посмотреть сообщение
То есть вы считаете, что для новичков выложенный дистрибутив 3.8.4 лишний?
Отнюдь Если адаптирован под современные версии PHP/MySQL я только ЗА.
Мне то вообще без разницы у кого и какой дистр установлен. Главное, что бы мой совет был полезным и не осложнил человеку жизнь. Как и почему я уже объяснил.
YURSHAT вне форума   Ответить с цитированиемОтветить с цитированием
Пользователь сказал cпасибо:
Veter (17.08.2015)
Старый 17.08.2015, 21:32 #90 (Ссылка)
Аватар для Veter
Администратор
 
Регистрация: 01.01.1970
Адрес: На wmboard
Моя смс: vBulletin 3.x.x, DLE, WordPress, XenForo
Сообщений: 9,224
Записей в дневнике: 17
Сказал(а) спасибо: 2,058
Поблагодарили 2,666 раз(а) в 1,930 сообщениях
Репутация: 2676
Veter Veter вне форума
Администратор
Дополнительная информация
По умолчанию

Ну значит нужно доделывать...
Ссылку на него удаляю.
Veter вне форума   Ответить с цитированиемОтветить с цитированием
Пользователь сказал cпасибо:
YURSHAT (17.08.2015)
Ответ

Опции темы

Ваши права в разделе
Вы не можете создавать новые темы
Вы не можете отвечать в темах
Вы не можете прикреплять вложения
Вы не можете редактировать свои сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.
Trackbacks are Вкл.
Pingbacks are Вкл.
Refbacks are Вкл.


Похожие темы
Тема Автор Раздел Ответов Последнее сообщение
Скачать vBulletin 4.х.x Veter vBulletin 4.x.x 8 02.03.2015 23:19
Где можно скачать шаблон на vBulletin 3.8.7? Bambuk Шаблоны vBulletin 4 08.08.2012 12:03
Как скачать видео? MariaLimur Вопросы от новичков 2 04.05.2010 23:24
Где скачать adobe dreamweaver? 1800color Программы и софт 2 28.04.2010 18:27
где можно скачать Redinamix? baghuetto Web дизайн 2 26.04.2010 21:37


Текущее время: 10:22. Часовой пояс GMT +3.

Powered by vBulletin®
Copyright ©2000 - 2018, WMboard.
Перевод: zCarot
 

Форум вебмастеров

Здесь делают сайты, учатся на них зарабатывать. Ты новичёк, и ничего не понимаешь в создании сайтов и в интернет заработке? Не знаешь ответа на вопрос по сайтостроению? Мучают вопросы сео оптимизации?

Не беда, присоединяйся к сообществу вебмастеров, и зарабатывай вместе с нами!